AnsweredAssumed Answered

Odd occurences with my Convotherm 4 oven.

Question asked by olivero on May 7, 2017
Latest reply on May 9, 2017 by olivero

I had an interesting problem last week with my Convotherm, C4ET 20.20 GS oven.

 

Its not all that old yet so I believe experience with these is pretty limited but let me try and explain what I got.

 

The unit has a touch screen, looks like its all it is and the brains of the operation or the main control board is directly behind it. when you take the service cover off, you can see the front of the board where everything plugs in, my particular problem was the bottom combustion blower wouldn't run, I tried reading their wiring diagram and its, well, confusing and not that easy to understand unless you really try.

 

So I went ahead and tried a couple of things, I tried finding where the power came into it, it has 2 plugs on it, both of which have 3 wires on them, its a 220V 50 hz blower...... 50hz... german..... grr..

 

So I looked for power on both, saw none but didn't think it was the right place regardless so I checked the top one and sure enough, 1 of the 2 did have 230 V on it so I checked the bottom one and there was no power, so I pulled the connector off the board and ohmed out the wires, all came through clean. I tried swapping the top blower to the bottom as well as the ignition module and still, no life.

 

Called Cleveland, said it might be the board, I had figured it might be a relay on the board supposed to switch power over but after spending some time figuring their wiring diagram, that didn't really make sense either so I was kind of lost. Figured the only way to really know was to check on the board with the unit running, tried removing the board and it didn't budge so I figured maybe I could get to it by removing the touch screen, turns out that's the way to do it. Popped the screen off and what do I see? Fuses...... They mounted fuses on the opposite side of the board.......... oh boy.. 5 hours of troubleshooting back and forth on the phone with Cleveland with 0 mention of this.

 

Checked the fuse matching the connectors location and sure as rain, it was blown. It was a 2 A, slow blow, ceramic, 250 V mini fuse. Drove down to radio shack, they had 1.6 A fast acting ones, figured it couldn't hurt. Put 1 in, ran the unit for 20-30 minutes, no problem.

 

Next day, chefs use it, cook for 45 minutes and it triggers the same error code, same problem, same fuse. Figured okay, I checked the A draw on that fan, it was less than 1 A so its gotta be the inrush, drove to some random speaker store, picked up the original type and put it in, ran it for 3 hours, no problem. Chefs ran it the next day for over 8 hours straight, no problems.

 

2 days later (today) same error code triggers, well that's embarrassing, check the unit again, figured okay its gotta be a wire problem or something dumb, ohm out the wires again, one of them no longer is showing a connection, trace the wire through and find a black cylinder on the wire, another fuse.... This time its a 1 A slow blow, 250 V in a littelfuse black cylinder. Its blown, great. back to Radioshack to get their 1 A fuse, picked up both the fast and slow, planning on putting in the fast acting one first after checking everything and see what happens, that way I am safe in case something slips me in the troubleshooting.

 

That's where I am at now, my first thought is when the first fuse blew (2A one) that it might have weakened the 1 A one since they are on the same line. OR the internal blower wheel is somehow compromised in a way that its messing things up. Have to take the blower off and disassemble the venturi to get to that wheel but I will if it comes to it. I am going to check the top fans A draw and see if its any lower or higher, maybe it will tell me something.

 

I could use some help on this, don't want to miss something this time so if you guys have any advice, please, do share it. 

 

izzygreenfixbearectofix

 

You guys got any input on this?

Outcomes